Question

Email Trigger with Email server

  • 10 February 2023
  • 2 replies
  • 135 views

Badge +4

Hi,

I am trying to use Email Trigger with Email server option but it seems to be not working. When I am using Outlook in the Trigger option it is working fine. Can you help me to resolve if there is any possible issues.
Email Server : Outlook.office365.com ; Port :993

Thanks,

Diksha


2 replies

Userlevel 5
Badge +9

@Diksha.M1 

Kindly check below KB

https://apeople.automationanywhere.com/s/article/Email-trigger-unable-to-detect-the-new-mail

First, please test by sending a sample email and observe where the email lands.

  1. If it lands directly into the Inbox folder, then just select the radio button "All incoming emails" on the right hand side.
  2. If it lands into a subfolder within the Inbox folder, then ensure that you select the additional option "Email in Folder" as per the screenshot below:

 

If your emails are coming into a subfolder, and you do not enable this option, then the emails will not be read and the trigger will just loop constantly without any results.


Generally speaking, when trigger works normally, the following message will be generated in the C:\ProgramData\AutomationAnywhere\BotRunner\Logs\TriggerListener.log file:

com.automationanywhere.bottrigger.email.task.EmailTask - run - Found new emails in time

 

Also, check the follow KB to troubleshooting Trigger.

https://apeople.automationanywhere.com/s/article/A2019--Triggers-not-working-on-Botrunner

Login in the botrunner in Control-Room to activate the trigger.

 

HTH

REgards

Userlevel 5
Badge +10

@Diksha.M1  what was the error you receiving?

Reply