Question

Developing an action with inline command

  • 29 September 2022
  • 9 replies
  • 24 views

I'm developing a custom A360 package and I want to know how to create an action and let me call an inline command. (e.g. convert string to Uppercase).

 

I'v found this post from AA documentation and I'v tried the script but it didn't work. I'm not sure what "Property" term means.

 

https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/developer/cloud-expose-action-property.html

 

Thank you in advance.

 

 


9 replies

Thank you @Tamil Arasu​  por your answer, but I can't find any tip or sample in the attached links.

 

I'm just trying to create an inline script like $Variable.String:toNumber$

Userlevel 3
Badge +7

Hi @Alvaro Gata​ ,

 

Once you have embedded the logic for the inline command you want to your SDK, you have to add four more properties to the CommandPkg attribute:

 

property_name="uppercase", 

property_description="Converts the string to upper case", 

property_type=DataType.STRING, 

property_return_type=DataType.STRING) 

 

The four commands inform intellisense on how to behave. If you want to return a string in uppercase, you have to first inform(property_name) intellisense that you have developed a logic that accepts strings(property_type) which spits out a string(property_return_type) with upper case.

 

The description(property_description) is for others to understand what it does and can be seen once you hover over it.

 

image 

Obviously, you can't use this since we already have an inline command that converts string to uppercase, so why not try creating something else, like returning a substring of a given string?

 

Kind Regards,

Ashwin A.K

Userlevel 3
Badge +7

Hi @Alvaro Gata​ ,

 

Please check out the below link

 

Build Your First Automation 360 Package with

 

https://developer.automationanywhere.com/learn/bot-developer-journey/creating-custom-packages/p>

Userlevel 3
Badge +7

Hi @Alvaro Gata​ ,

 

Did you perform a clean shadow build before importing it into the CR?

 

Kind Regards,

Ashwin A.K

Hi @Ashwin A.K​ ,

 

Thank you for your answer. I did all that you say: I already added four properties to the Command PKg attribute and I copied all the script from documentation link.

 

Now with the goal to create a different inline command, I'v created an action to concatenate an input string with suffix "_123". But still I can't see my property name in the auto-complete box.

 

Java

Of course, i always perform clean build shadowJar command before uploading my package into the CR.

 

I'm working with SDK 2.5.0 and always logs BUILD SUCCESSFUL.

Userlevel 3
Badge +7

Hmm understood.

 

Hi @MICAH SMITH​  could you please help us out here?

We are unable to create custom inline operations even after following whatever was detailed in the documentation here.

 

Any pointer would be most appreciated.

 

Kind Regards,

Ashwin A.K

Problem solved!

 

There was a little mistake in my package. In the file "package.template", in JSON property "name", I had my package name with a space between two words. This format is incompatible with AA package property format.

 

When I rewrote the name without spaces, the Package Property worked successfully.

 

Thanks all of you so much for your help

 

Best regards

 

Álvaro Gata

Userlevel 3
Badge +7

Awesome! And huge thank you for coming back to provide an update here so people who have this issue in the future can find the help they need!

Reply