Question

Customer is using Azure Virtual Desktops as a runner machine . And it’s username for the device is xxxx@microsoft.in ( contains “@“ character as it’s on Azure) . When they try to execute bot as unattended it gives error for device credntial.

  • 9 November 2022
  • 6 replies
  • 42 views

Badge +2

Currently we are running bots by keeping the runner devices open . We cannot log off the session after execution as Bot unable to Autologin due to "@" character issue in Device username.

 

Please help here


6 replies

Userlevel 6
Badge +9

Hello @Aman Dubey​  Will you try setting the Autologin device credentials in CR as 'DomainName\Username' format?

Badge +2

Hi Sajith,

 

It is Azure Cloud Virtual Machines Login and Usernames are in EmailID format.

Userlevel 6
Badge +9

@Aman Dubey​ Could you run 'whoami' in the command prompt in the cloud VM and see in which format you get the username.

Badge +2

Hence at current state we have to keep the VDI open and then run the Bots with Domain/Usename.

But we want to logoff Device after every Process Execution but currently we are using setting Keep the system Open.

Badge +2

 

Hi Sajith, @Sajith Sudhakaran​ 

Domain/Username is working only when the Azure VDI is OPen. If VDI is not open then it need actual username (Contains "@") but Bot not accepting "@" symbol in Device username Field.

Hope I am able to explain the issue.

Userlevel 6
Badge +9

Once we log off the VDI, is it still up and running? Are we using NonPersistent or Persistent VDI?

Reply