Custom Package: Gradle Build Error with JDK

  • 12 April 2023
  • 0 replies

Userlevel 3
Badge +9

I am building a custom package using the Automation Anywhere SDK.


I am using IntelliJ. Environment is set up to run with Correto 1.8 JDK and language level 8 (default for the JDK). I am limited to 1.8 because our company uses AdoptOpenJDK 1.8.


The package cannot even build out of the box and returns the following build error:

A problem occurred evaluating root project 'myProject'.
> java.lang.UnsupportedClassVersionError: com/automationanywhere/gradle/codegen/CommandJsonMergerPlugin has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Java class file version 55 is Java 11. AdoptOpenJDK 1.8 is on Java 8 I believe.


Is there any way I can bypass this error? I was wondering if there is a way to modify the Automation Anywhere classes so that they are compatible with my JDK level.


Custom Packages are my first time using Java, so there may be lots of options that I don’t know about. I will hear any suggestions.


I absolutely cannot change my JDK or Java version due to enterprise environment constraints.



0 replies

Be the first to reply!