Question

Couldn't find "" Sheet in Macro Excel Using Excel Advanced

  • 31 January 2024
  • 3 replies
  • 84 views

Badge

I’m using Excel Advanced to open a macro file on version 21.112 or above. Recently, I’ve ben running into an issue where the macro file does open but the bot crashed saying it cannot find a sheet. “Unable to find sheet '' in file …” is the message I receive when attempting to run.

The first time this issue appeared was on 12-20-2023, and ever since, the bot has continued to crash when being run manually or scheduled. 

I’ve attempted to select a specific sheet in the same Open Excel Advanced action, but it provide the same error, just with the selected sheet within the apostrophes of the message above. I’ve also tried unhiding all sheets, graphs, and everything in-between, but same issue.

Does anyone have a similar issue or have a work around solution? I need the file to be a local excel session so I can manipulate the data within.

 


3 replies

Badge

Any update on this , I am also facing the same issue 

Badge

Hello, any news ? I encounter the same problem with a robot that has been working for more than a month.

Badge

I was able to get around this issue by manually opening the Excel file, then manually doing a save as to a new location, then moving the newly saved file to the required location to replace the original file.  It seems like it may be some sort of corruption in the file or failure to read by AA.  But this resolved the issue for me.  Hope this helps!

Reply