Question

Bot not retrieving data from one column in database query

  • 4 October 2022
  • 2 replies
  • 18 views

I am developing a bot which reads from a SQL database. All works well with the exception of one column in the table. The bot does not retrieve any text from that column - when storing that column's contents to a data table, that row is blank. All other columns' contents are read/exported fine.

 

The data type of the column is VARCHAR(MAX) and its contents are the body of an email. My query works fine in MySQL but nothing is returned from the query when used within Automation Anywhere. I have tried removing the carriage return (CHAR(13)), the line feed (CHAR(10)), and tab (CHAR(9)) in the SELECT statement, thinking that could be the cause of the problem but the data table row for this column is still blank. I have tried exporting the data to CSV using every encoding option and Automation Anywhere still retrieves nothing, although the queries work fine in MySQL. What could be the reason for this?

 

Example of the SLEECT statement as used in the 'Export to data table' and 'Read from database' actions I have attempted in Automation Anywhere:

 

SELECT REPLACE(REPLACE(REPLACE(Body,CHAR(10),''),CHAR(13),''),CHAR(9),'') AS 'Example'

FROM DB.TABLE

WHERE EmailID = xxxxx


2 replies

Userlevel 4
Badge +8

Hello @Laura Gipson​ 

 

Thank you for posting in the Automation Anywhere user community forum!

 

Based on the description, we understand that the issue will require deeper troubleshooting and investigation.

 

Please use the below link to create a Support Case and we will be glad to get in touch and help further!

 

How to create a support case :

https://apeople.automationanywhere.com/s/article/How-to-Open-a-Support-Case

 

If you don't have access to the link, please email the AA Support team at "apeopleopsteam@automationanywhere.com" to request access.

 

Kind Regards,

Jigar Solanki 

Automation Anywhere 

Badge

Me pasa lo mismo , temporalmente mientras lo solucionan 

SELECT CONVERT(NVARCHAR(100), field) as “Fiel” FROM prueba

Reply