Azure Blob Storage via SFTP

  • 17 January 2024
  • 4 replies
  • 129 views

Badge +2

Hi team,

 

I want to put file to azure blob container via SFTP connection. 

I use ftp/sftp command but I am getting error: ‘use valid connection parameters and try again.’

 

Does anyone have experience please? I saw that it uses SSH2 and I also saw a note that aa360 does not support SSH1. Do you think it is feasible to put file to blob container via SFTP?

 

Thanks a lot

Eva

 


4 replies

Userlevel 3
Badge +8

Hi @EvaG,

While Azure Blob supports file uploads via SFTP, ensure your connection parameters are accurate and your SFTP server supports SSH2 protocol, as Automation 360 is incompatible with SSH1.

Automation 360 only supports SSH2 for secure data communication. If you have migrated bots that were configured with SSH1, they will work in Automation 360 and will be configured with the SSH2 connection type by default. This is part of the system's upgrade to ensure more secure and efficient operations.

Thank you. 

 
Badge +2

Thank you Ravi for your reply.

The server uses SSH2. I tried various combination but I am getting the same error over and over again:

Can you please check whether I chose the server type correctly (below) and do you happen to have some example how the user name and server name should look like? 

Thank you

Userlevel 3
Badge +8

Hi @EvaG,

Could you please try connecting to the blob using a supported ftp client listed here, just to ensure you able to connect the blob successfully with the same credentials. 

https://learn.microsoft.com/en-us/azure/storage/blobs/secure-file-transfer-protocol-support

Just FYI, FTP and FTPS aren't supported for Azure Blob Storage.

 Thanks. 

Badge +2

Hi @ravi.pothana 

Thank you for your advice. I tried to connect via Filezilla but w/o any luck. It seems we have firewall issue so I am still working on it:)

Reply