Question

AA do not click on web element instead just put the focus on the element

  • 20 October 2022
  • 1 reply
  • 28 views

Hello,

 

We are observing that A360 capture command for web elements is not clicking on the element(in some cases) instead it is just focusing the control over the element. We tried using both Click and Left Click actions and both seems not clicking the element.

 

The same command works fine on the same elements in question in V11 without any issues but not on A360. We migrated a task bot with capture command from V11(which is working) but not working in A360 post migration. We also tried recapturing the element on A360 post migration and even then the element is not being clicked.

 

This is how Save button is visible before running the capture command with Click action on the Save button.

err1Notice how the Save button is now focused instead of click action.

after-err2 

As a workaround, we are are adding a keystroke command(ENTER) after capture command is ran(as capture command is bringing the element to focus and highlighted) but we want to know why we are not able to click on the element.


1 reply

Userlevel 3
Badge +7

Hi @Carlos Vargas​ ,

 

I've noticed this as well, my resolution was to switch the click type to Left Click which is a hardware event.

If that doesn't work either, then like you mentioned, we have to highlight the element before using an ENTER keystroke.

 

Not the best approach imo, but lets hope that the product team looks into this.

 

Kind Regards,

Ashwin A.K

Reply