Question

A360 ServiceNow Package - Where to enter "sysparm_fields"

  • 21 September 2022
  • 4 replies
  • 11 views

Badge +2

In the Command "ServiceNow: Get Multiple Records", we have the provision "Encoded Query String (i.e. sysparm_query) (optional)" to enter the sysparm_query. But I don't see any provision to enter the "sysparm_fields".

 

Is there any way to enter the sysparm_fields in the command ?

 

Note: I'm trying to get some field values (Variables) from a RITM. So, my value in the sysparm_fields will be like variables.first_name, variables.last_name, variables.department etc. to get the respective values.

 

 

The same Method in Postman would look like this:

 postman


4 replies

Badge +4

@Ambarish Rao​ 

You can use the sysparm query field to do so.

sys_id=$RITM_ID$&sysparm_fields=approval,$RITM_REQUESTER_TYPE_VARIABLE_ID_LIST[0]$,$RITM_REQUESTER_EMAIL_VARIABLE_ID$,u_approvers

 

 

image

Badge +2

Hello @Sumit Kumar​ ,

 

Thank you for sharing the solution.

 

I have tried to do the same thing with my env, But I'm getting an error like "An unexpected error occurred. null"

 

Am I missing something here? Can you please guide.

 

SNOW_GetMultipleRecordsNote:

1) I have tried using the actual sys_id instead of RITM1234567

2) Tried "Values to Return for Each Dictionary in List" option.

Still the same.

 

Badge +4

@Ambarish Rao​ Please update the package.

Then you can use it like this:

image

Badge +2

@Sumit Kumar​ - Thank you so much for alternative method. It worked 🙂

Reply