Question

Unable to run Bot in Community Edition

  • 21 December 2022
  • 7 replies
  • 558 views

Badge +5
Experiencing issues while running the bot in the Community Edition and it got frozen in the Pending Execution status and have tried the following workarounds  
1. Deleting the Device - it Throws an error saying "  Cannot delete a device, as it is part of an active bot deployment"
2. Tried Overwriting the Bot Agent (Uninstalling and Reinstalling the Bot Agent) - which expects to delete the registered device, but we are unable to perform the action.
3. Tried Restarting the Bot Services 
4. Stopping the Processes related to Automation Anywhere in Task Manager
 

Still, we are facing the same issue, attaching the below screenshots for your reference

It is getting close to the deadline for Bot Submission to complete the Master Certification. We request your immediate support to resolve this issue ASAP. 

 

.

 

Is there any way to fix this issue? 


7 replies

Badge +2

Hi @Kayal 2500 

 

  1. Did you try first killing the bot or stopping the execution. Then It would ideally allow you to delete. And from task manager check if any hidden processes are running
  2. Try disabling if that works

 

cheers

Badge +5

Hi @gorthianil , 

  1. Yes - Unfortunately there is no option (permission) available in the community Edition to Stop or kill the bot under Inprogress Section
  2. Tried that too but no luck 
Userlevel 7
Badge +13

Hi @Kayal 2500 ,

 

Let me know whether you are familiar with Postman to make API call. If so, I can share steps to reset the device.

Badge +5

Hi @Padmakumar ,

 

  Yes, I am familiar with the Postman tool. Could you please share the steps with me, I'll try it  
 

Userlevel 3
Badge +6

Dear @Kayal 2500,

 

It sounds like you are experiencing an issue with a bot in Automation Anywhere Community Edition that is stuck in the "Pending Execution" status. This can be a frustrating issue, as it can prevent you from running the bot or making any changes to it.

There are a few things you can try to troubleshoot this issue:

  1. Make sure that the bot agent is running and connected to the control room. If the bot agent is not running or is experiencing connectivity issues, the bot may not be able to execute.

  2. Make sure that there are no other tasks or processes running that could be conflicting with the bot. If there are other tasks or processes running on the device, they may be preventing the bot from executing.

  3. Try restarting the bot agent and the control room. This can help to reset any temporary issues that might be causing the bot to get stuck in the "Pending Execution" status.

  4. If you have tried all of the above steps and the issue persists, you may need to contact Automation Anywhere support for further assistance.

 

Regards,

Badge +2

@Kayal 2500 

 

You can try checking the documentation for api

 

https://<your Control Room URL>/swagger/ui/?url=/swagger/api/v3/wlm-api-supported.yaml#/

 

cheers

Userlevel 7
Badge +13

Hi @Padmakumar ,

 

  Yes, I am familiar with the Postman tool. Could you please share the steps with me, I'll try it  
 

 

You can reset the device by using an API call through Postman as shown below. Let me know if it worked.

 

Note: You need to authenticate first with your control room through Postman and should have an authorization key before starting this.

 

If you have further doubts to use Postman, please refer below link. 

https://community.automationanywhere.com/developers-blog-85009/intro-to-control-room-api-with-postman-85035

 

Reply