Question

Scripts created earlier fail to work after some time

  • 2 August 2023
  • 1 reply
  • 18 views

Badge +2

Hi,

 

I am trying to automate a remote desktop application. I wrote a script (workflow) some time back and executed it and it worked fine. I then shut down my machine and then after a few hours, I again opened the remote desktop machine from my computer. However, when I run the same script again, it simply fails to work. At the very first step it fails saying that the object could not be located on the screen. Now, even if a recapture the object for that step, it then fails at the second step citing the same reason. So, in short, I am compelled to recapture objects for each of my steps again.

Can anyone please tell me as to why this happens and is there any workaround to this problem?

Please help ASAP as it is very urgent.

 

Thanks in advance,

Ramesh Rangarajan


1 reply

Userlevel 3
Badge +12

There are too many possible causes for this to count them all. You’re simply going to need to go through where it is failing to determine what is happening. For example, if it is failing on capturing an element on a web page, and you say recapturing seems to fix it, likely the XPath or some other attribute on that element has changed. You need to look at the step that is failing, make note of the attributes being captured, then re-capture the object and see what has changed. 

 

Reply