Question

Cant Connect Local Device to Control Room

  • 21 March 2022
  • 9 replies
  • 185 views

Device appears to be connected but cant select it from the dropdown

 

Screenshot 2022-03-21 174257 https://drive.google.com/file/d/16zc78c3-XzXrie_44FEqpRdPOA0yxGfX/view?usp=sharing/a>

 

User info appear but cant view details

Screenshot 2022-03-21 173729I have reinstalled & restarted service, I have moved to another device too but same problem.


9 replies

Userlevel 6
Badge +15

Hi @Somesh Banerji​ ,

 

Refer to this Knowledge Article and you can try with the below options,

 

1) Go to Devices -- My Devices -- and remove the device

2) Go to Control Panel -- Services-- Restart the Bot Agent Service

3) login into A2019/A360 and try to run

 

 

Thanks!

Userlevel 6
Badge +16

Hi @Somesh Banerji​ ,

 

Could you try below steps,

 

  1. Stop the bot agent services
  2. Open the folder location "C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere"
  3. Delete the AA-DB.mv and AA-DB.trace files.
  4. Start the Bot agent Service
  5. Try to run the bot with the latest package and let us know the outcome of the bot

 

Userlevel 6
Badge +10

Hello @Somesh Banerji​  If the above suggestions doesnt help, you may look into the Nodemanager.log file fro the Botagent Vm to find the because of the issue. Nodemanager.loge default location is C:\ProgramData\AutomationAnywhere\BotRunner\Logs\Node_Manager.log

I deleted the Device from the Control Room & Uninstalled the Agent & deleted the AA-DB.trace file before reinstalling the Agent. Then I tried to reconnect the local device but stuck at....

 

Screenshot 2022-03-23 122254The Node_Manager.log has the following errors...

 

(Configuration.java:166) - Loading properties from C:\Program Files\Automation Anywhere\Bot Agent\config\nodemanager.properties

2022-Mar-23 Wed 12:11:16.636 ERROR [main] - com.automationanywhere.nodemanager.Configuration - {} - <init>(Configuration.java:170) - Could not load properties from C:\Program Files\Automation Anywhere\Bot Agent\config\nodemanager.properties: C:\Program Files\Automation Anywhere\Bot Agent\config\nodemanager.properties (The system cannot find the file specified)

2022-Mar-23 Wed 12:11:16.645 INFO [main] - com.automationanywhere.nodemanager.Configuration - {} - reloadRegistrationProperties(Configuration.java:204) - Error reading property file registration.properties: C:\WINDOWS\system32\config\systemprofile\AppData\Local\AutomationAnywhere\registration.properties (The system cannot find the file specified)

2022-Mar-23 Wed 12:11:16.647 INFO [main] - com.automationanywhere.nodemanager.Configuration - {} - <init>(Configuration.java:177) - File watcher is not enabled.

2022-Mar-23 Wed 12:11:17.653 INFO [main] - com.automationanywhere.nodemanager.service.impl.CacheDataAccessServiceImpl - {} - upgradeIfRequired(CacheDataAccessServiceImpl.java:79) - LOCAL_PATH_LENGTH is :4096 no upgrade required

Userlevel 6
Badge +10

Instead deleting some files, rename the Automation Anywhere folder from "C:\Windows\System32\config\systemprofile\AppData\Local\" and try reinstalling the Botagent

Deleted all folders, Reinstalled the Agent but its still the same.

Can this be a server side profile config issue?

 

https://drive.google.com/file/d/16zc78c3-XzXrie_44FEqpRdPOA0yxGfX/view?usp=sharing

Userlevel 6
Badge +10

You may validate the Websocket connectivity from Botagent machine following the article below. Enabling WSS protocol is mandatory to establish the connectivity between CR and Botagent.

https://apeople.automationanywhere.com/s/article/How-to-validate-Websocket-connection

Screenshot 2022-03-24 105216URL you shared did not work but I used a 3rd party web service to test & WSS may not be the problem.

 

 

Nodemanager.loge:-

 

https://drive.google.com/file/d/1pqE03ONq445E4tHicF1cyjHKOh0dnGXv/view?usp=sharing/p>

Did not find any solution so switched to Microsoft Power Automate & its working faster too.

 

I knew AA could not be my long term solution with frequent Control Room outages & delay in starting the bot...so was always ready to switch but was hesitant because of the effort involved.

 

It was not difficult & I am glad that I finally switched.

 

If you are a single user with small but important tasks on AA Community edition start building a back up on PA & switch in time.

 

Reply