Solved

Bot stuck in pending execition

  • 1 November 2023
  • 6 replies
  • 335 views

Badge +4

Hi all, I am facing the issue as below but on Community Edition.

https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress-Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on-A2019-CLOUD-environments/

 

Bot is stuck on Pending Execution Stage and I am unable to remove/reset devices or stop the bot

Following the steps in the KB is ok until trying to remove the device.

{
  "code": "json.deserialization.exception",
  "details": null,
  "message": "Invalid request parameters"
}

my Community Edition URL: https://community.cloud.automationanywhere.digital/

 

 

Could someone please assist on this issue of Bot stuck at pending Execution stage?

icon

Best answer by Abhay Naik 1 November 2023, 06:58

View original

6 replies

Userlevel 3
Badge +7

Hi,

Could you please confirm below steps.

  1. Were you able to Get the authentication token with the first API call? 
  2. Have you used the Auth-token in second API call?
  3. Could you send the json body content of the second API Call?
Badge +4

Hi Abhay, thank you for responding.

  1. Yes
  2. Yes
  3. Yes.Please refer to screenshots attached

 

Badge +4

i have also tried this command in the body:

{
  "allDevices": {
  }
}

 

the resulting output:

{

    "message": "Can reset only device registered by you"

}

Badge +4

i have also tried:

Perform the device reset with Postman using another device. Additionally, if deployment get stuck, delete the file AA-DB located in C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere 

but it didnt work,

i have also tried another device and used Postman to follow the above steps again with the same results

Userlevel 3
Badge +7

Hi,

The Device ID seems to be wrong.

Please follow these steps to get the device ID

  1. Go to Device page under Manage.
  2. Click on the device that you want to remove. Since its community edition you will have only one device there and you will be able to reset only that. So reset all API call won’t be helpful here

  3. Once you click on the device. Check the url of that page. You will get a number value at the later end. That will be you device ID. it is the numerical value mostly. So copy that and put it in you Json body in second call.

    Hope this will solve your issue.

    Thanks​​​​​​​

Badge +4

Hi Abhay, I have managed to resolve this with your help.

 

I mistakenly took the name of the device as the Device ID.

Hope this helps anyone else that might face this issue in the future.

Reply