Solved

A360 WLM and Queue

  • 8 January 2024
  • 5 replies
  • 42 views

Badge +1

Hi ,

I have created a simple WLM Queue and a Task Bot Associated with that queue in A360 version.

I have added users as Queue Consumers for that queue. Queue Owner and Consumer users are under same developer role.

When I am trying to run this task bot with the queue in A360 control room using available device pool , the “Run Bot with Queue” is disabled and not able to run.

Q1. Do we need to add any specific role to the users to run bot with queue or any permission need to be given to a device pool or bot runners where I can run Bot with Queue ?

Q2. Do we have any A360 Control room API to insert/retrieve Work Items to a specific Queue ?

Q3. Do we have any A360 Control room API to Call WLM queue passing different parameters ?

icon

Best answer by Padmakumar 8 January 2024, 12:51

View original

5 replies

Userlevel 7
Badge +13

Hi @AmitavaR104611 ,

 

First of all, please ensure the following to see the list of available queues:

  • You do not have the AAE_Admin role.
  • Your role is added to Queue > Consumers.
  • The bot and queue work item templates are identical.
  • Create a role with access to the Workload and then add it to the Consumers section of the queue.
 
 
Badge +1

Hi ,

Thanks for your reply .

So any user with the role with access to the “Workload”  can able to run Queue after adding as Consumer ?

What I have seen I can only able to run Bot with Queue in A360 Public selecting queue, device pool etc.  .  There is no option testing such queues in Private Mode ? In Private when I am trying run the Bot with Queue , “Run Bot with Queue” button is disabled .

Userlevel 7
Badge +13

Hi ,

Thanks for your reply .

So any user with the role with access to the “Workload”  can able to run Queue after adding as Consumer ?

What I have seen I can only able to run Bot with Queue in A360 Public selecting queue, device pool etc.  .  There is no option testing such queues in Private Mode ? In Private when I am trying run the Bot with Queue , “Run Bot with Queue” button is disabled .

 

The bots have to be checked in to the public folder in order for the bots to qualify to be run with queue.

 

You can find more details on Queues here.

 
 
Badge +1

Hi ,

Thanks for the clarification .

In some example , I have seen people are inserting Work Item to the Queue using workload command from TaskBot which is present in Private folder . How it is possible ?

But I am not able to run TaskBot from Private ( i have associated the Queue as Work Item template)  , when I am trying to Run this . at beginning , it’s asking for input values for all the columns present in the Queue Work item and its not taking value from Queue .

Userlevel 7
Badge +13

Hi ,

Thanks for the clarification .

In some example , I have seen people are inserting Work Item to the Queue using workload command from TaskBot which is present in Private folder . How it is possible ?

But I am not able to run TaskBot from Private ( i have associated the Queue as Work Item template)  , when I am trying to Run this . at beginning , it’s asking for input values for all the columns present in the Queue Work item and its not taking value from Queue .

 

Please check this tutorial for a better understanding.

Workload Management with Automation Anywhere (youtube.com)

 

Reply