Question

Not able to delete existing device in Community Edition Control Room AA360. Error:- Device is part of Active Deployment (no tasks are running although)

  • 19 September 2022
  • 9 replies
  • 33 views

Tried these things to resolve the issue-

1- Uninstalling Bot agent and deleting Device from CR

2- Reinstalled Bot agent and tried to add device (throwing error only 1 device can be added although device already present is in disconnected state)

3- tried restarting Bot agent services

 

Nothing worked till now, Please suggest/guide me to resolve the issue.

 

Thanks and Regards,

Dilip Kumar Jaiswal

 


9 replies

Userlevel 3
Badge +7

Hi @Dilip Kumar Jaiswal​ ,

 

Please check out the below KB.

 

https://apeople.automationanywhere.com/s/article/A360-Getting-error-Cannot-delete-device/p>

 

Thanks!

Userlevel 4
Badge +8

Hi @Dilip Kumar Jaiswal​ ,

 

Can you navigate to manage >> Devices, select your device and delete it from CR. Then try restarting the Bot Agent service and give a shot.

 

Checkout below KB,

 

https://apeople.automationanywhere.com/s/article/A360-Getting-error-Cannot-delete-device/p>

@Khaled Mostafa​ please help in this regards.

Hi @ChanduMohammad S​ tried that too but i did not worked.

It is not allowing me to delete that device itself saying active deployment is going on.

Userlevel 4
Badge +8

Hi @Dilip Kumar Jaiswal​ 

 

Can you restart your machine, stop bot agent service and try deleting the device?

Userlevel 4
Badge +8

Hi @Dilip Kumar Jaiswal​ ,

 

This is strange, can you try one last attempt. Can you try API way [ Checkout below link ]

 

https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress-Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on-A2019-CLOUD-environments/p>

Hi @Tamil Arasu​ tried it but did not worked

Hi @ChanduMohammad S​ 

 

Firstly tried this only but it did not helped.

Userlevel 4
Badge +8

Please check if any proxy settings or firewall settings are implemented on your machine which may be interfering with the Bot agent functionality,

Reply