Question

I am trying to install a bot from the Bot Store and once it finishes loading I get an error saying "Do not have sufficient permissions.". What is causing that?


I am trying to install a bot from the Bot Store and once it finishes loading I get an error saying "Do not have sufficient permissions.". What is causing that?

10 replies

Userlevel 3
Badge +7

Hi @Ashley Jones​ ,

 

If you have just the AAE_Basic Role tagged to your Profile, then you will only be able to View the Botstore.

To install bots, you either have to create a Custom role with the required permission shown in the screenshot below:

 

imageOr you can simply map the AAE_Bot Developer Role to your profile.

 

Kind Regards,

Ashwin A.K

Hi Ashwin A.K.

 

I have that in my profile.

 

AA 

Any thoughts?

Userlevel 3
Badge +7

Hi @Ashley Jones​ ,

 

As per the documentation, you should be good

 

imageimageimage 

image 

Kind Regards,

Ashwin A.K

Hello Ashwin

 

I downloaded this Bot to my PC and tried to upload it, to my control room which is when I go the error.

 

For some reason I can't connect to the Bot Store directly from my Bot. I try to do it and got the error below.

 

AA 2 

I'm a bit lost. 😐

Userlevel 3
Badge +7

Hi @Ashley Jones​ ,

 

From the error description, it seems as though the Bot Server is down.

But that is odd, since I was able to access it right now.

Maybe you could give it a try after a couple of hours?

If its anything urgent, I'd encourage you to raise a ticket with AA, since this doesn't look like an issue from our end.

 

Kind Regards,

Ashwin A.K

Userlevel 3
Badge +7

Hi @Ashley Jones​ ,

 

Yes, and that is what you should use to log into the Bot Store instance in CR.

Were you unable to do so?

 

Kind Regards,

Ashwin A.K

 

Userlevel 3
Badge +7

Hi @Ashley Jones​ ,

 

Sorry, I seem to have left out a crucial detail, the BotStore Cred is not the same as your Login Cred.

 

It is separate, i.e., you have to create a BotStore Account from here and then use that to log into the BotStore.

 

image 

image 

Kind Regards,

Ashwin AK

No. I was not able to connect to the bot store from my robot. I got the following error.

 

AA 2

Hi Ashwin.

 

Yes I have already registered with the Bot store, it is a different password to my AA access.

Userlevel 4
Badge +8

Hello @Ashley Jones​, Please refer steps from below KB article and it should resolve the issue faced.

https://apeople.automationanywhere.com/s/article/Unable-to-Log-in-to-Bot-Store-from-control-room/p>

Reply