Question

Hello everyone, I am facing an issue with the copy file command on the runner.

  • 2 July 2022
  • 4 replies
  • 22 views

Actually, I created a bot in AA version 11 (creator) but when I move the bot on runner it gives the error that the source path doesn't exist. But the path is same for both the creator and runner. The creator bot runs perfectly but it's not working on the runner side.

Please help me with this issue, I don't understand the root cause.4bdd2f1f-cad4-45cf-8bfd-fc1b7c49f15c


4 replies

Userlevel 3
Badge +7

Hi @Hardik Singhal​ ,

 

Could you please check manually whether that file is available or not? in the mentioned location. or you can add a message box in the front of the copy file command to check the file path.

 

 

Thanks!

 

 

Hi @Tamil Arasu​ 

 

Thanks for your answer but I checked it manually the file is on the exact path as the creator and I also added the message box to identify the path then copy the message path and search in file explorer. Both are the same and the file is also available there but still, it shows the path doesn't exist.

 

Userlevel 3
Badge +7

Please give it try by installing the latest version of the client.

Userlevel 3
Badge +7

Hi @Hardik Singhal​ 

 

As a test, could you try looping through each file in that particular directory and display the filepaths in a message box?

 

Once the iteration reaches the file you are interested in, copy that file path and check if the bot is able to work with that file path.

 

Kind Regards,

Ashwin A.K

Reply