Question

Does Bot Runner require an interactive session at all time. I was under the impression that at runtime the control room would login the user on the remote bot runner and run the bot. Right now if I have no user session on the server the bot fails.

  • 28 June 2022
  • 6 replies
  • 49 views

I do have the device login credentials set for the bot runner user and I did not select the "Attest device credentials"

I suspect that this is related to the following info "If auto-login fails, configure the Local Security Policy settings. For example, in Windows, select Security Settings > Local Policies > Security Options. Enable the Interactive logon: Do not require CTRL+ALT+DEL option" but not sure.

So this is working right now until the server gets re-cycled.

Any help would be appreciated with this.

 

Here is the error reported by the control room:

com.automationanywhere.nodemanager.exception.UserLoginException: {"message":"User not logged into the machine.","details":"This may be due to multiple reasons.\n\n1. Check that your username and domain name is correct in the provided device login credentials.\n2. Login into the machine as that user before running the bot.\n3. Some other user may have logged into the machine.\n\n\n\nIf you continue to see this message, please contact your system administrator.","correctiveAction":"","code":"user.not.logged.in"}

I


6 replies

Userlevel 4
Badge +8

Hi @Rock Morin​ ,

 

Good Day!

 

Recommendation: Enable the Interactive logon: Do not require CTRL+ALT+DEL option to ensure your device is able to bypass the screen to create a user session.

When you deploy a bot from the Control Room on a device, Bot agent receives the deployment and creates an interactive user session for deployment. If the option is disabled, the Bot agent will not be able to bypass the screen to create a user session. Therefore, we recommend you enable this option.

 

Ref doc: https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/bot-agent/bot-agent-auto-login-support.html/p>

 

For the error "User not logged into the machine." please refer the below KB article

https://apeople.automationanywhere.com/s/article/Error-unable-to-run-the-bot-error-Code-user-not-logged-in

 

Thank you

So if we enable Interactive Logon what would be the mitigating control against the security issue mentioned in the microsoft docs https://docs.microsoft.com/en-us/windows/security/threat-protection/security-policy-settings/interactive-logon-do-not-require-ctrl-alt-del

Is there some network restriction (IP filtering or white listing) that we can do so only the control room has external access to our bot runner?

Userlevel 4
Badge +8

Hi @Rock Morin​ ,

Thanks for the revert, please refer the below KB article which describes the technical details on why the Ctrl+Alt+Del to be enabled.

https://apeople.automationanywhere.com/s/article/Technical-details-of-Ctrl-Atl-Del/p>

I click the link but I get "We've encountered an error while loading this page. Please check your URL or try to reload the page."

 

Userlevel 4
Badge +8

Hi @Rock Morin​ ,

The URL is accessible and Apeople login is required. Please check again and let me know if still facing the issue.

 

image

Must be a different login then the one I use to post questions. I type the url as shown in the picture and still got Invalid Page/ Page Load Error.

Reply