Solved

csv to Excel paste


Badge +1
  • New Member
  • 4 replies

As a beginner I run through the Automation360 video “Getting started with building bots”. Capturing a csv table and paste into Excel doesn´t go well. Everything is pasted in column A, not column separated as the csv file describes. So the bot doesn´t find correct data in column A and B etc. 
How should I make the bot separate the columns directly in Excel? The parameters are: ANSI, comma separated, .csv file.  

icon

Best answer by TSG 5 January 2023, 15:17

View original

10 replies

Userlevel 4
Badge +8

Hi @TSG ,

Welcome to the community!

Can you change the Row Delimiter to New Line and give a try in c.v step?

 

Badge +1

Thank you!
It is already row delimiter “new line”, the rows are ok.
But only that all is in column A.
 

 

Userlevel 4
Badge +8

Can you expand Column A and check whether the data is available in only column A?

Badge +1

:) 

 

Userlevel 4
Badge +8

Hi @TSG 

Can you try to run the bot again, don't think there is any miss from your end. Tested same from my end am able to get the data, PFB screenshots for your reference

 

Userlevel 4
Badge +7

@TSG Change radio button to Append to the existing file 

Badge +1

Thank you all for the advice, but still the same. I begin to beleive it´s an issue in my Excel. I have had problem with paste in correct format before, will investigate this with my company support. I will report back to you :)

Userlevel 4
Badge +8

Thank you all for the advice, but still the same. I begin to beleive it´s an issue in my Excel. I have had problem with paste in correct format before, will investigate this with my company support. I will report back to you :)

Welcome @TSG 

Userlevel 7
Badge +10

Hi @TSG ,

 

When you CSV in your spreadsheet editor (Excel, for example), it shows all of the data in a single column, instead of splitting them across columns.

The reason behind this behavior is that CSV files (Comma Separated Values) are splitting data into columns using " , " as separator by default. But in certain countries, the default value used as separator is " ; " instead.

To resolve this issue, within your open CSV file, you can click on the Data tab, select Convert and choose commas.

 

To change the settings for future Excel documents:

Go to your Settings page clicking on the link in the top-right corner of your screen (You have to be an admin)

In the Localization module, change the "List separator for exports" field to  "comma ( , )"

 

To change the settings for your Windows computer: 

Go to Start > Settings > Control Panel > Regional and Language Options. 
Click “Customize”. 
Enter “,” for “List Separator”

Badge +1

@Padmakumar you just hit it!
I live in a region where semi-colon is the default list separator, so I guess that I simply edit the bot and change from comma to semi-colon.
Voilá! It works nicely. 
/TSG

Reply