Question

Error An unexpected error occurred. Java heap space Please contact system administrator.

  • 12 January 2023
  • 6 replies
  • 58 views

Badge +4

Estoy pasando datos de un excel a una tabla de base de datos pero me da el siguiente error, al abrir el excel 

 

An unexpected error occurred. Java heap space Please contact system administrator. 


6 replies

Userlevel 4
Badge +7

Hola @cacordero ,

Este error puede ser debido a la cantidad de información en memoria java que esta procesando. Puede referirse al siguiente KB para incrementar la memoria del proceso 

https://apeople.automationanywhere.com/s/article/Java-heap

Solo considerar los recursos existentes en la VM como limitante.

Si el error persiste, podría intentar reducir la cantidad de información que procesa el bot, es decir, filtrarla para un conjunto más pequeño de resultados 

 

Saludos.

Badge +4

Si se logran ingresar 2 reportes de excel a la tabla de base de datos, al 3er reporte lo deja a la mitad y muestra ese msj de error

Userlevel 4
Badge +7

@cacordero ,

Gracias por su respuesta. ¿Ese tercer reporte se puede subir por separado? Algunas acciones son  incrementar el tamaño de memoria java según el KB que se compartió.  Otra idea es verificar si algo dentro de la información pueda estar causando alguna inconsistencia, como por ejemplo que la información contenga varias comillas simples (´) o símbolos especiales dentro del dataset.

 

Saludos,

Badge +4

Si cada reporte lo ngreso por medio de un loop que recorre las filas y va ingresando a la tabla, el primer y segundo reporte es casi igual al 3ero pero falla en un paso de open el excel y da ese error como de memoria o espacio

 

Intente lo de agregar la linea al archivo pero no funciono

Userlevel 4
Badge +7

@cacordero 

Verifiqué que el reporte en Excel no contenga celdas en blanco adicionales (sin contenido) y elimínelas.

Saludos

 

Userlevel 4
Badge +7

@cacordero 

Solution 1 :
Steps to follow : 

  1. Edit the “nodemanager.properties” file under “C:\Program Files\Automation Anywhere\Bot Agent\config” 
  2. Add this line to configure more heap memory  bot.launcher.jvm.options=-Xmx4096m  
  3. Restart the bot agent service.

Solution 2: 
Steps to follow :
1. Login with admin user in A360 Control Room.
2. Go to Administration > Settings > Devices > Advanced Options and click edit.
3. Add the below string under "Bot launcher JVM options" including double quotes :
"-Xmx8192m"

Reply